网页 综合 更新时间 2025-03-01 00:00:00

RFC 9743: Specifying New Congestion Control Algorithms

自动蜘蛛 www.rfc-editor.org 正文约 2945 字
RFC 5033 discusses the principles and guidelines for standardizing new congestion control algorithms. This document obsoletes RFC 5033 to reflect changes in the congestion control landscape by providing a framework for the development and assessment of congestion control mechanisms, promoting stability across diverse network paths. This document seeks to ensure that proposed congestion control algorithms operate efficiently and without harm when used in the global Internet. It emphasizes the need for comprehensive testing and validation to prevent adverse interactions with existing flows.¶
This memo documents an Internet Best Current Practice.¶
This document is a product of the Internet Engineering Task Force (IETF). It represents the consensus of the IETF community. It has received public review and has been approved for publication by the Internet Engineering Steering Group (IESG). Further information on BCPs is available in Section 2 of RFC 7841.¶
Information about the current status of this document, any errata, and how to provide feedback on it may be obtained at https://www.rfc-editor.org/info/rfc9743.¶
Copyright (c) 2025 IETF Trust and the persons identified as the document authors. All rights reserved.¶
This document is subject to BCP 78 and the IETF Trust's Legal Provisions Relating to IETF Documents (https://trustee.ietf.org/license-info) in effect on the date of publication of this document. Please review these documents carefully, as they describe your rights and restrictions with respect to this document. Code Components extracted from this document must include Revised BSD License text as described in Section 4.e of the Trust Legal Provisions and are provided without warranty as described in the Revised BSD License.¶
2. Specification of Requirements
3. Guidelines for Authors
3.1. Evaluation Guidelines
3.2. Document-Status Guidelines
4. Specifying Algorithms for Use in Controlled Environments
5. Evaluation Criteria
5.1. Single Algorithm Behavior
5.1.1. Protection Against Congestion Collapse
5.1.2. Protection Against Bufferbloat
5.1.3. Protection Against High Packet Loss
5.1.4. Fairness Within the Proposed Congestion Control Algorithm
5.2. Mixed Algorithm Behavior
5.2.1. Existing General-Purpose Congestion Control
5.2.2. Real-Time Congestion Control
5.2.3. Short and Long Flows
5.3.1. Differences with Congestion Control Principles
5.3.2. Incremental Deployment
6.1. Paths with Tail-Drop Queues
6.2. Tunnel Behavior
7.1. Active Queue Management (AQM)
7.2. Operation with the Envelope Set by Network Circuit Breakers
7.3. Paths with Varying Delay
7.4. Internet of Things and Constrained Nodes
7.5. Paths with High Delay
7.6. Misbehaving Nodes
7.7. Extreme Packet Reordering
7.8. Transient Events
7.9. Sudden Changes in the Path
7.10. Multipath Transport
8. Security Considerations
9. IANA Considerations
10.1. Normative References
10.2. Informative References
Appendix A. Changes Since RFC 5033
访问原文 返回搜索 https://www.rfc-editor.org/rfc/rfc9743.html
本页为82搜索生成的网页快照,内容来自站内索引;演示数据的原文链接仅作示例。