网页
综合
更新时间 2026-11-15 01:00:54
Media Types
自动蜘蛛
www.iana.org
正文约 2938 字
RFC 2046 specifies that Media Types (formerly known as MIME types) and Media Subtypes will be assigned and listed by the IANA.
Procedures for registering Media Types can be found in RFC 6838, RFC 4289, and RFC 6657. Additional procedures for registering media types for transfer via Real-time Transport Protocol (RTP) can be found in RFC 4855.
Per Section 3.1 of RFC 6838, Standards Tree requests made through IETF documents will be reviewed and approved by the IESG, while requests made by other recognized standards organizations will be reviewed by the Designated Expert in accordance with the Specification Required policy. IANA will verify that this organization is recognized as a standards organization by the IESG.
Some early registrations have no registration template. The absence of a template does not imply a different or reduced registration status.
Per Section 12.5.1 of RFC 9110, use of the "q" parameter name to control content negotiation would interfere with any media type parameter having the same name. Hence, the media type registry disallows parameters named "q".
The 'example' media type is used for examples. Any subtype following the media type syntax may be used in those examples. No subtype can be registered with IANA. For more information see RFC 4735.
Note: The occurrence of an 'example' media type as a media type outside of examples, e.g. in a Content-Type header, is an error and should be reported to the implementor. RFC 2045; RFC 2046 specifies that Content Types, Content Subtypes, Character Sets, Access Types, and conversion values for MIME mail will be assigned and listed by the IANA.
Other MIME Media Type Parameters
See RFC 6657 for information about 'charset' parameter handling for text media types.
Approved by IESG on 2024-05-02 in accordance with RFC 6838, Appendix A. https://datatracker.ietf.org/doc/minutes-interim-2024-iesg-10-202405021400/.
Approved by IESG on 2024-10-17 in accordance with RFC 6838, Appendix A. https://datatracker.ietf.org/doc/minutes-interim-2024-iesg-21-202410171400/.
Approved by IESG on 2025-04-17 in accordance with RFC 6838, Appendix A. https://datatracker.ietf.org/doc/minutes-interim-2025-iesg-08-202504171400/.
Approved by IESG on 2025-09-25 in accordance with RFC 6838, Appendix A. https://datatracker.ietf.org/doc/minutes-interim-2025-iesg-19-202509251400/.
Approved by IESG on 2026-02-05 in accordance with RFC 6838, Appendix A. https://datatracker.ietf.org/doc/minutes-interim-2026-iesg-03-202602051500/.
Approved by IESG on 2026-04-16 in accordance with RFC 6838, Appendix A. https://datatracker.ietf.org/doc/minutes-interim-2026-iesg-07-202604161400/.
Approved by IESG on 2026-08-06 in accordance with RFC 6838, Appendix A. https://datatracker.ietf.org/doc/minutes-interim-2026-iesg-14-202608061400/.
The IANA functions coordinate the Internet’s globally unique identifiers, and are provided by Public Technical Identifiers, an affiliate of ICANN.
本页为82搜索生成的网页快照,内容来自站内索引;演示数据的原文链接仅作示例。